织梦CMS - 轻松建站从此开始!

主创网

当前位置: 主页 > 财经 >

通达信最好的致命指标,主创不看你就损失大了(源码 主图 公式)

时间:2017-06-20 21:38来源:admin 作者:admin 点击:
公式说明:任何指标都不可能让人傻瓜式操作都赚大钱,都必须要自己总结一些规律,并且要结合市场情况对指标的可信度做出判断。今天把选股公式的一些体悟跟大家分

公式说明:任何指标都不可能让人傻瓜式操作都赚大钱,都必须要自己总结一些规律,并且要结合市场情况对指标的可信度做出判断。今天把选股公式的一些体悟跟大家分享一下,说的不对说的不好请大家多指正,共同探讨才能让自己的技术进步!

涨停位置:

A2:=MA(C,18);

A3:=(C-A2)/A2*100>=-9.9 AND C

谷底涨停:A3 AND C/REF(C,1)>1.099,COLORRED;

B1:=BARSLAST(LLV(C,100));

B2:=C/REF(C,1)>=1.095;

B3:=MA(C,10)>REF(MA(C,10),1);

低位涨停: B2 AND B3 AND O/LLV(C,100)<1.3 AND B1<20;

D2:=C/REF(C,1)>=1.095;

D3:=MA(C,20)>REF(MA(C,20),1) AND MA(C,55)>REF(MA(C,55),1);

中位涨停: D2 AND D3 AND O/LLV(C,100)>1.3 AND O/LLV(C,100)<1.5;

一阳穿六均线 选股预警公式指标源码:

MA5:=MA(C,5);

MA13:=MA(C,13);

MA30:=MA(C,30);

MA60:=MA(C,60);

MA120:=MA(C,120);

MA144:=MA(C,144);

收盘低:=REF(C,1)

收盘高:=CROSS(C,MA5) AND CROSS(C,MA13) AND CROSS(C,MA30) AND CROSS(C,MA60) AND CROSS(C,MA120) AND CROSS(C,MA144);

选股XG:收盘低 AND 收盘高;

老鸭头选股公式:

D!LYT (老鸭头) 缺省周期:日线

MA5 := MA(close,5);

MA10 := MA(close,10);

MA60 := MA(close,60);

pday1 := barslast(cross(ma5,ma60));{5日均线上穿60日均线}

pday2 := barslast(cross(ma10,ma60));{10日均线上穿60日均线,至此形成鸭颈部}

pday3 := barslast(high=hhv(high,pday2));{形成头部,要下跌}

pday4 := barslast(cross(ma10,ma5));{下跌后,5日均线和10日均线死叉}

pday5 := barslast(cross(ma5,ma10));{回落不久,5日均线和10日均线形成金叉,形成嘴部}

a1:= pday1>pday2 and pday2>pday3 and pday3>pday4 and pday4>pday5 and pday5<5;

a2:= count(cross(ma10,ma5),pday2)=1;

A1 AND A2;

四合一金叉选股公式:

M1:=MA(CLOSE,5);

M2:=MA(CLOSE,10);

MA1:=MA(VOL,5);

MA2:=MA(VOL,10);

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

A1:=DEA;

F1:=DIF;

K1:="KDJ.K";

J1:="KDJ.J";

金叉1:=CROSS(M1,M2);

金叉2:=CROSS(MA1,MA2);

金叉3:=CROSS(F1,A1);

金叉4:=CROSS(J1,K1);

选1:=金叉1 AND 金叉2 AND 金叉3 AND 金叉4;

选2:=金叉1 AND 金叉2 AND 金叉3;

选3:=金叉2 AND 金叉3 AND 金叉4;

选4:=金叉1 AND 金叉2 AND 金叉4;

选5:=金叉1 AND 金叉3 AND 金叉4;

选股:选1 OR 选2 OR 选3 OR 选4 OR 选5;

一阳穿三线选股公式:

MA5:=MA(C,5);

MA10:=MA(C,10);

MA30:=MA(C,30);

低:=REF(C,1)

高:=CROSS(C,MA5) AND CROSS(C,MA10) AND CROSS(C,MA5);

选股:低 AND 高;

次日涨停公式:

A : MA(CLOSE,26);

UP: A + 2*STD(CLOSE,26);

LOWER: A - 2*STD(CLOSE,26);

W1:=C=HHV(C,20);

W2:=BARSLAST(W1);

W3:=IF(W2>0,REF(C,W2),REF(C,W2));

W4:=CROSS(C,REF(W3,1));

DRAWICON(W4 AND COUNT(W4,5)=1,LOW,3);

捕捉中短线牛股指标:

WX:=MAX(MA(C,5),MAX(MA(C,10),MAX(MA(C,20),MAX(MA(C,60),MA(C,120)))));

ZS:=IF(CROSS(C,WX) AND COUNT(C>WX,5)=1,1,0); MA5:=MA(C,5);

MA10:=MA(C,10);MA20:=MA(C,20);MA60:=MA(C,60);MA120:=MA(C,120);

A1:=CROSS(MA5,MA10);B1:=C>MA60 AND MA5>MA60 AND MA10>MA60;

C1:=MA60>MA120;D1:=A1 AND B1 AND C1;

ZB:=CROSS(MACD.MACD,0) AND C>MA(C,5);

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;AB:=CROSS(K,D);

第一阳起爆:COUNT(D1,5)=1>0 AND COUNT(ZS,3) AND ZB AND AB;

日线盘中抓涨停:

盘中满足下面所有条件的个股,出现报警。

1、量比大于2.5;

2、去掉一字涨停板个股和开盘高于6%的个股(因为这样的个股盘中操作价值已经不大);

3、13日均线角度上穿45度;

源码:

A1:=VOL/ref(MA(VOL,5),1);A2:=O/ref(c,1)<1.06;

jd:=atan((MA(C,13)/ref(MA(C,13),1)-1)*100)*57.3;

XG:A1>2.5 AND A2 and cross(jd,45);

与庄共舞:

ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE

M1:=EMA(ABV,12);

M2:=EMA(ABV,26);

MTM:=CLOSE-REF(CLOSE,1);

MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));

MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));

MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));

MTGJ:=C-REF(C,1);

ZLGJ:=100*EMA(EMA(MTGJ,9),9)/EMA(EMA(ABS(MTGJ),9),9);

MAZL:=MA(ZLGJ,5);

主力进出:=MMS>REF(MMS,1) AND ZLGJ>REF(ZLGJ,1) AND CROSS(ABV,M2)AND ABV>REF(ABV,1) AND M1>REF(M1,1) ANDM2>REF(M2,1);

主进主轨:=ABV>M2 AND CROSS(ABV,M1) AND CROSS(ZLGJ,MAZL);

主力进出 OR 主进主轨;

高控盘捕捉大黑马指标公式:

ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}

SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}

ZSHTL:=SHCM/(ZLCM SHCM)*100;{//散户套牢筹码比率}

ZZLKP:=ZLCM/(ZLCM SHCM)*100;{//主力控盘筹码比率}

ZCMZL:=MA(ZLCM SHCM,13);{//市场筹码总量}

ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}

ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}

ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}

ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}

SH8:=EMA(ZSHTL,8);

DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);

{散户套牢筹码}

STICKLINE(C>0,ZSHTL,ZZLKP,0,0),COLOREEEEEE;

{散户筹码警戒}

STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,1,0),COLORAAAAAA;

{主力控盘筹码}

STICKLINE(C>0,ZZLKP,0,0,0),COLORBLUE;

{铸顶风险区}

STICKLINE(ZZLKP>75,ZZLKP,0,2,0),COLORFFFFFF;

{顶部:(ZZLKP>75),COLORFFFFFF;}

{主力筹码警戒}

STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,4,0),COLORRED;

{筑底散兵坑}

STICKLINE(ZSHTL>=90,ZZLKP,0,5,0),COLOR66FFCC;

{底部:(ZSHTL>=90),COLOR66FFCC;}

{筹码总量上升}

IF(ZCMZL,ZCMZL>REF(ZCMZL,1),DRAWNULL),COLOR0066FF,LINETHICK1;

{增量资金};

{//------【数值显示】}

散户套牢系数:INTPART(ZSHTL),COLORYELLOW;

主力控盘系数:INTPART(ZZLKP),COLORCYAN;

资金流入强度:ZJLRQD,LINETHICK2,COLORRED;

市场筹码总量:INTPART(ZCMZL),COLORWHITE,NODRAW;

轴:50,COLORGREEN,DOTLINE,LINETHICK1;

DRAWTEXT(CROSS(主力控盘系数,轴),轴 10,'高度控盘'),COLORYELLOW;

{指标说明:资金流入强度下穿0轴,股票必抛};

三条均线锁牛股:

MA10:= MA(CLOSE,10),COLORGREEN;

MA20:= MA(CLOSE,20),COLORYELLOW;

MA50:= MA(CLOSE,50),COLORCC66CC;

MA50A:=IF(MA10>MA20 ANDMA20>MA50,MA50,DRAWNULL),COLORRED,LINETHICK1;

MAA:=MAX(MA20,MA50);

买点0:=COUNT(MA10>MA20 AND MA20>MA50,5);

买点2:=COUNT(MA10>MA20 AND MA20>MA50,1);

买点3:=COUNT(MA50>MA20 AND MA20>MA10,1);

买点1:=BARSLAST(REF(买点3,1)=1 AND CROSS(MA10,MA20) ANDC/REF(C,1)>=1.0);

转势1:=COUNT(REF(买点3,1)=1 AND CROSS(MA10,MA20) ANDC/REF(C,1)>=1.0,21);

买点4:=COUNT(CROSS(MA10,MA20),3);

买点5:=COUNT(CROSS(MA10,MA50),3);

DRAWTEXT((买点1<=34 AND转势1>=1 AND C/REF(C,买点1)<=1.25 AND转势1<=21 AND MA10>=REF(MA10,1) AND MA10>MA20 ANDMA20>MA50 AND 买点0>=1 ANDCROSS(C,MA10))

OR(买点4>=1 AND 买点5>=1 AND C>MA10)OR (REF(买点3,1)=1 ANDCROSS(MA10,MA20) ANDC/REF(C,1)>=1.09),L-0.27,'●'),COLORDDDDDD;

凹底“倍量伸缩”战法:

伸倍量柱:=REF(V>=REF(V,1)*1.5 AND C>O,1) ANDV<=REF(V,1)*0.9;

T:=BARSSINCEN(伸倍量柱,8);{178448-WEN98编写};

不跌破:=LLV(C,T 2)>=REF(L,T 1);

缩倍双阴:=COUNT(CO,2) ANDMA(V,2)<=REF(V,2)*0.7;

倍量伸缩:= REF(伸倍量柱,1) AND缩倍双阴;

凹底:=(MA(C,3)-LLV(L,20))/LLV(L,20)<0.1;

涨停:=C>=(1.10*REF(C,1)-0.004);{178448-WEN98编写}

XG1:=COUNT(伸倍量柱,8)>=2 AND 倍量伸缩 AND凹底 AND 不跌破 AND T>=3 AND COUNT(涨停,30);

XG:COUNT(XG1,10) ;

寻找底分型选股公式:

V00:= HIGH

V01:= HIGHREF(LOW,1);

V02:= HIGH>REF(HIGH,1) AND LOW

V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);

V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW

AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);

V1:= COUNT(V00,6)>=3 AND COUNT(V01 OR V02,5)=0 AND LLVBARS(LOW,6) = 1 AND HHVBARS(HIGH,6) >= 5 AND V03;

V2:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 2 AND HHVBARS(HIGH,7) >= 6 AND V04;

V3:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 1 AND HHVBARS(HIGH,7) >= 6 AND V03;

V4:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 2 AND HHVBARS(HIGH,8) >= 7 AND V04;

V5:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 1 AND HHVBARS(HIGH,8) >= 7 AND V03;

V6:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 2 AND HHVBARS(HIGH,9) >= 8 AND V04;

V7:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 1 AND HHVBARS(HIGH,9) >= 8 AND V03;

V8:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 2 AND HHVBARS(HIGH,10) >= 9 AND V04;

V9:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 1 AND HHVBARS(HIGH,10) >= 9 AND V03;

V10:= COUNT(V00,11)>=3 AND COUNT(V01 OR V02,10)<=5 AND LLVBARS(LOW,11) = 2 AND HHVBARS(HIGH,11) >= 10 AND V04;

XG: V1 OR V2 OR V3 OR V4 OR V5 OR V6 OR V7 OR V8 OR V9 OR V10;

在加入综合选股时,XG=1。

(责任编辑:admin)
织梦二维码生成器
顶一下
(0)
0%
踩一下
(0)
0%
------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片
栏目列表
推荐内容